PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV Mobile 24 → editer ou visualiser donnée d'une base de donnée sqlite (.db)
editer ou visualiser donnée d'une base de donnée sqlite (.db)
Débuté par Monsieur VAN PACHTENBEKE, 02 juil. 2018 17:11 - 7 réponses
Membre enregistré
25 messages
Posté le 02 juillet 2018 - 17:11
bonjour,

afin de débuger mon application windev mobile sous androide (tablette samsung), j'ai réussit a delocaliser ma base de donnée sur la carte sd via la commnade:
MaConnexion1..Source = "/sdcard/mon_dossier/Base.db"
MaConnexion1..Provider = hAccèsNatifSQLite

mais le probleme c'est que je trouve pas coment faire pour l'ouvrir via mon pc et visualiser les enregistrement.

auriez vous une idée.

faut 'il que je modifie ma base de donnée pour utiliser une base Hyperfile sql car les fichier fic peuvejt etre lu par WDMap ???

merci d'avance pour votre aide.
Membre enregistré
25 messages
Posté le 02 juillet 2018 - 17:37
je me repond en partie a moi même lo.

j'ai transformer mes basse de donnée en hyperfile sql classic avec une nouvelle connexion et utilise ce code:

HChangeRep("*", "/sdcard/mon_dossier/")

ils sont bien exporter sur la carte sd et ils sont editable via wdmap juse avec un double click.
il faut juste les copier coller sur le disque dur du pc sinon cela cause des erreurs.

parcontre qu'elle est l'avantage d'utiliser une sqlite vis à vis d'une hyperfile sql ???
Posté le 02 juillet 2018 - 21:00
pour accéder a ta carte sd interne il faut utilisé adb
sinon a partir de l'explorateur tu copie la base SQLite sur ton PC et elle est visible avec un plugin firefox par exemple.
si tu la met en .fic tu la copie pareil et tu la visionne avec wdmap
Posté le 02 juillet 2018 - 21:07
avantage SQLite : un seul fichier regroupant toute la base et fonctionne depuis la version 1 d'Android
fic directement lisible avec wdmap fonctionne a partir de la version 4 d'Android mais nécessite d'incorporer le framework de base de données (32 bit seulement actuellement)
Membre enregistré
25 messages
Posté le 03 juillet 2018 - 11:46
merci pour votre aide.

j'ai encore un probleme car la fonction
HChangeRep("*", "/sdcard/mon repertoire/bd/")

ne crée qu'une seul de mes 4 table de mon analyse dans le repertoire specifié sur la carte sd

j'ai ajouter alors ceci:
sCheminDonnées est une chaîne = "/sdcard/mon repertoire/bd/"
SI PAS fRépertoireExiste(sCheminDonnées) ALORS
fRepCrée(sCheminDonnées)
FIN

SI fExtraitRessource("xxx.fic", sCheminDonnées + "xxx.fic") = Faux ALORS
Info("erreur = " + HErreurInfo()) //donne erreur mais pas de texte d'erreur ???
FIN

fExtraitRessource("xxx.ndx", sCheminDonnées + "xxx.ndx")
fExtraitRessource("xxx.mmo", sCheminDonnées + "xxx.mmo")

SI PAS HChangeRep(desriptif_full_setting, sCheminDonnées) ALORS
Erreur(HErreurInfo()) //pas d'erreur ici
FIN


1) j'ai vu qu'il fallait peut etre inclure dans l'apk les fichier de l'annalyse mais je ne les trouve pas dans mon dossier du projet en cours ???

2) remarque dans mon projet je n'ai que l'analyse mais ne devrais je pas créer les ficher .fic et .nds sur mon pc.

3) comment créer ces fichier avec windev mobile ?
Message modifié, 03 juillet 2018 - 11:50
Membre enregistré
25 messages
Posté le 03 juillet 2018 - 13:56
voila j'ai trouver une solution,

1) dans l'analyse cliquer sur chaque table et crer le fichier de donées de chaque table de l'analyse
2) generer l'application androide et inclure tout les fichier table créer (feront donc partie de l'apk
3) faire ce code:
sCheminDonnées est une chaîne = "/sdcard/mon repertoire/bdd/"

SI PAS fRépertoireExiste(sCheminDonnées) ALORS

fRepCrée(sCheminDonnées)

fExtraitRessource("xxx.fic", sCheminDonnées + "xxx.fic")
fExtraitRessource("xxx.ndx", sCheminDonnées + "xxx.ndx")

fExtraitRessource("yyy.fic", sCheminDonnées + "yyy.fic")
fExtraitRessource("yyy.ndx", sCheminDonnées + "yyy.ndx")
FIN

HChangeRep("*", "/sdcard/mon repertoire/bdd/")


je vais esayer de l'ameliorer en utilsant
fFichierExiste () a la place de fRépertoireExiste()


sin il y a un ecrasement du fichier a chaque demarage de l'application
Membre enregistré
25 messages
Posté le 03 juillet 2018 - 16:10
pour la forme voici la derniere syntax plus propre
sCheminDonnées est une chaîne = "/sdcard/mon repertoire/bdd/"

SI fFichierExiste(sCheminDonnées + "xxx.fic") = Faux ALORS
fExtraitRessource("xxx.fic", sCheminDonnées + "xxx.fic")
fExtraitRessource("xxx.ndx", sCheminDonnées + "xxx.ndx")
FIN

HChangeRep("*", "/sdcard/mon repertoire/bdd/")
Membre enregistré
25 messages
Posté le 24 juillet 2018 - 16:44
j'ai maintenat une autre question,

comment faire pour que le dossier "/mon repertoire" soit supprimer à la désinstallation de l’application sur androïde ?