PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV 22 → Choix de répertoire pour enreg. TXT
Choix de répertoire pour enreg. TXT
Débuté par Pierre COLIN, 19 mar. 2017 15:06 - 2 réponses
//hostimage.webdev.info/avatars/default.gif
Posté le 19 mars 2017 - 15:06
Dans le code ci-après, quand je précise    fRepEnCours("C:\")     ça va dans    C:\Users\Pierre COLIN\AppData\Local\VirtualStore     sinon dans le répertoire en cours.

//fRepEnCours("C:\")
Num_Fic = fCrée("TEST.TXT", foLecture)
SI Num_Fic <> -1 ALORS
    // Écriture dans ce fichier
    WCh1="TOTO"+TAB+"TATA"+TAB+"TITI"+TAB+"TUTU"+RC
    WEnt0 = fEcrit(Num_Fic, WCh1)
    SI WEnt0 = -1 ALORS
        Erreur("Erreur")
        Ferme()
    SINON
        fFerme(Num_Fic)
    FIN
FIN

Comment paramétrer pour envoyer TEST,TXT dans C : (racine) et sur le bureau ?
Merci de vos conseils.
//hostimage.webdev.info/avatars/default.gif
Posté le 19 mars 2017 - 22:53
Coucou,

Variables d'environnement windows reconnues

https://technet.microsoft.com/fr-fr/library/cc749104(v=ws.10).aspx

Et definitivement je te recommande pas d ecrire directement dans la racine du disque dur.

Au pire si tu doit partager un chemin d acces entre application, utilise une valeur dans la base de registre, mais au possible
laisse la racine des disques dur tranquille :p

Charly
//hostimage.webdev.info/avatars/default.gif
Posté le 20 mars 2017 - 10:23
Le 19/03/2017 à 14:06, Pierre COLIN a écrit :
Dans le code ci-après, quand je précise fRepEnCours("C:\") ça va
dans C:\Users\Pierre COLIN\AppData\Local\VirtualStore sinon dans
le répertoire en cours.

//fRepEnCours("C:\")
Num_Fic = fCrée("TEST.TXT", foLecture)
SI Num_Fic <> -1 ALORS
// Écriture dans ce fichier
WCh1="TOTO"+TAB+"TATA"+TAB+"TITI"+TAB+"TUTU"+RC
WEnt0 = fEcrit(Num_Fic, WCh1)
SI WEnt0 = -1 ALORS
Erreur("Erreur")
Ferme()
SINON
fFerme(Num_Fic)
FIN
FIN

Comment paramétrer pour envoyer TEST,TXT dans C : (racine) et sur le
bureau ?
Merci de vos conseils.


en precisant directement le chemin :)

fcrée("C:\TEST.txt",foEcriture)
ps: pour ecrire dans un fichier, il vaut toujours mieux l'ouvrir en mode
ecriture :)

my 2 cents...