PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV 22 → Impossible de créer le fichier .rpl
Impossible de créer le fichier .rpl
Débuté par Sylvere72, 15 mai 2017 21:02 - 5 réponses
//hostimage.webdev.info/avatars/CXebt5MMigpENg4StTiuPA
Membre enregistré
40 messages
Posté le 15 mai 2017 - 21:02
Bonjour
J'ai abandonné la replication avec hfsql classique. .. visiblement ca marche pas. .. ou les explications ne sont pas suffisantes

Du coup j'essaie avec hfsql client serveur comme maître.

Et la réplication fonctionne avec le Go... 1ere victoire (aucun fichier wer avec l'exe d'ailleurs mais j'ai 3 fichier .wix.syn...)

Mais ... quand je cree l'installations et que j'installe l'application, (avec les 3 fichier )
La réplication plante quand je lance la synchro

Les hfsql classic locaux sont inexistants il doit donc les synchroniser

Le message indique que le fichier .rpl ne peut pas etre copié dans le programdata/acssi

???? depuis quand on ne peut pas écrire dans le programdata ????


Merci de votre aide
J'ai l'impression d'etre neuneu
//hostimage.webdev.info/avatars/8zWSAZEAfDyBpnod1ClA
Membre enregistré
111 messages
Posté le 16 mai 2017 - 00:22
Yop,

T'as copier tes fichiers maitre ?



Si tu trouve pas repost, j'te ferais un tuto, mais sa doit vraimment venir du fait que tu n'as pas copier les fichier maitre au bon endroit

--
Charly CanDo.
Forg en Nouvelle-Zélande ;-) - In üs we trust
//hostimage.webdev.info/avatars/8zWSAZEAfDyBpnod1ClA
Membre enregistré
111 messages
Posté le 16 mai 2017 - 00:23
Coucou

Et les droits !

IUSR a toute les permissions :
C:\ProgramData\ReplicSRV

Basiquement c ton server IIS (ou apache) qui a pas les droits pour ProgramData , pourtant c bien expliquer qui faut lui filer a la main ^^ ton erreur vient de la ^^
--
Charly CanDo.
Forg en Nouvelle-Zélande ;-) - In üs we trust
Message modifié, 16 mai 2017 - 00:30
//hostimage.webdev.info/avatars/8zWSAZEAfDyBpnod1ClA
Membre enregistré
111 messages
Posté le 16 mai 2017 - 00:24


--
Charly CanDo.
Forg en Nouvelle-Zélande ;-) - In üs we trust
//hostimage.webdev.info/avatars/CXebt5MMigpENg4StTiuPA
Membre enregistré
40 messages
Posté le 16 mai 2017 - 10:32
merci charly !!!:merci:

j'ai ouvert les droits sur 2 répertoires dans mes documents/base (que j'utilise avec windev)
et sur mes documents/base que je veux utiliser avec le client

Quand je le fais sur la machine de développement "GO" ca marche nickel !!!!

C'est quand je cree l'installeur que ca deconne

Je crée l'installateur.

Quand j'installe je fais pointer via un HchangeRep vers "mes documents/baseutil"

Puis je clique sur synchronisation voir code ci-dessous :
- ReplicOuvre OK
- replicsynchronise >> ERREUR "La synchronisation a échoué : " (aucun message de plus)

Déjà pourquoi ca ne passe pas par RéplicInitialise ce devrait être le cas puisse que c'est la premiere fois ??
Est-ce qu'il faut que l'enlève le .WER des fichiers de l'installeur ?
<Repinst>\ACSSI-Doc.exe
<Repinst>\ACSSIDOC.wer
<Repinst>\ACSSIDOC\20_a_00A.syn
<Repinst>\ACSSIDOC\ACSSIDOC.rpl
<Repinst>\ACSSIDOC\ACSSIDOC.wir


Merci de votre Aide
Sylvere

==================
SI InternetConnecté() ALORS
SI RéplicOuvre("ACSSIDOC", "", "avrsiwebservice.pcscloud.net", "LOG", "PASS") ALORS
ToastAffiche("Synchronisation Ouverte",toastCourt,cvMilieu,chCentre,VertFoncé)
SINON
Erreur("L'ouverture de la synchronisation a échoué : " , ErreurInfo(errMessage))
RETOUR
FIN

// Initialise la réplication en passant les paramètres
SI RéplicInfo("ACSSIDOC", replicInitialisée) = Faux ALORS
SI RéplicInitialise("ACSSIDOC", gsNomsoc) ALORS
ToastAffiche("La première synchronisation a réussi",toastCourt,cvMilieu,chCentre,VertFoncé)

SINON

Erreur("La première synchronisation a échoué : " , ErreurInfo(errMessage))
RETOUR
//ToastAffiche("La première synchronisation a échoué",toastCourt,cvMilieu,chCentre,RougeFoncé)

FIN

FIN

// Lance la synchronisation
SI RéplicSynchronise("ACSSIDOC", replicaImmédiat) ALORS
ToastAffiche("Synchronisation terminée",toastCourt,cvMilieu,chCentre,VertFoncé)
SINON
ToastAffiche("La synchronisation a échoué",toastCourt,cvMilieu,chCentre,RougeFoncé)
Erreur("La synchronisation a échoué : " , ErreurInfo(errMessage))
RETOUR
FIN
SINON
ToastAffiche("Vous êtes Hors connexion, la synchronisation est impossible",toastCourt,cvMilieu,chCentre,RougeFoncé)
FIN
==================
//hostimage.webdev.info/avatars/CXebt5MMigpENg4StTiuPA
Membre enregistré
40 messages
Posté le 18 mai 2017 - 13:26
personne ?