PC SOFT

FORUMS PROFESSIONNELS
WINDEVWEBDEV et WINDEV Mobile

Accueil → WINDEV 22 → Fatal Error
Fatal Error
Débuté par Garry ALLEN, 06 fév. 2016 20:37 - 3 réponses
//hostimage.webdev.info/avatars/C8yKtKYaHR8EChG2WFuA
Membre enregistré
20 messages
Posté le 06 février 2016 - 20:37
I just opened a Project that I completed for a customer a few months ago. I was planning on adding an enhancement that they requested but I got the following error when I attempted to just run it with the GO button.
*************************
The description of the logical file <GPU_Element> stored in the analysis is not compatible with the one stored in the physical file <C:\My Projects\Cemetery3\EXE\Gpw_Cemetery3\GPU_Element>. Unable to access the file.
The <NameTargetD> item of <GPU_Element> file described in the analysis does not exist in the file.

----- Technical Information -----

Project : Cemetery3

What happened?
The description of the logical file <GPU_Element> stored in the analysis is not compatible with the one stored in the physical file <C:\My Projects\Cemetery3\EXE\Gpw_Cemetery3\GPU_Element>. Unable to access the file.
The <NameTargetD> item of <GPU_Element> file described in the analysis does not exist in the file.

Error code: 70016
Level: fatal error (EL_FATAL)
WD55 error code: 16

Dump of the error of 'wd200hf.dll' module (20.0.115.2).
Identifier of detailed information (.err): 72136
Debugging information:
IEWDHF=32.10
Module=<WDHF>
Version=<20.0.115.2>
Additional Information:
EIT_LOGICALTABLENAME : <GPU_Element>
EIT_PATHFIC : <C:\My Projects\Cemetery3\EXE\Gpw_Cemetery3\GPU_Element>
EIT_PATHWDD : <D:\SOURCE.VI200066\WDGPU\Ecr.US\WDGPU\WDGPU.wdd>
***********************************
I had made no changes to the project yet and I haven't got the slightest idea what the problem is. Re-compilng and synchronization did not help.

--
Garry
//hostimage.webdev.info/avatars/default.gif
Posté le 07 février 2016 - 00:11
Hi Garry,

there was a changed made in the analysis and that change was not
reported into that specific physical file.

Just open your analysis and run the file structure updater

Best regards

--
Fabrice Harari
International WinDev, WebDev and WinDev mobile Consulting

Ready for you: WXShowroom.com, WXReplication (open source) and now WXEDM
(open source)

More information on http://www.fabriceharari.com


On 2/6/2016 2:37 PM, Garry ALLEN wrote:
I just opened a Project that I completed for a customer a few months
ago. I was planning on adding an enhancement that they requested but I
got the following error when I attempted to just run it with the GO button.
*************************
The description of the logical file <GPU_Element> stored in the analysis
is not compatible with the one stored in the physical file <C:\My
Projects\Cemetery3\EXE\Gpw_Cemetery3\GPU_Element>. Unable to access the
file.
The <NameTargetD> item of <GPU_Element> file described in the analysis
does not exist in the file.

----- Technical Information -----

Project : Cemetery3

What happened?
The description of the logical file <GPU_Element> stored in the analysis
is not compatible with the one stored in the physical file <C:\My
Projects\Cemetery3\EXE\Gpw_Cemetery3\GPU_Element>. Unable to access the
file.
The <NameTargetD> item of <GPU_Element> file described in the analysis
does not exist in the file.

Error code: 70016
Level: fatal error (EL_FATAL)
WD55 error code: 16

Dump of the error of 'wd200hf.dll' module (20.0.115.2).
Identifier of detailed information (.err): 72136
Debugging information:
IEWDHF=32.10
Module=<WDHF>
Version=<20.0.115.2>
Additional Information:
EIT_LOGICALTABLENAME : <GPU_Element>
EIT_PATHFIC : <C:\My Projects\Cemetery3\EXE\Gpw_Cemetery3\GPU_Element>
EIT_PATHWDD : <D:\SOURCE.VI200066\WDGPU\Ecr.US\WDGPU\WDGPU.wdd>
***********************************
I had made no changes to the project yet and I haven't got the slightest
idea what the problem is. Re-compilng and synchronization did not help.

--
Garry
//hostimage.webdev.info/avatars/C8yKtKYaHR8EChG2WFuA
Membre enregistré
20 messages
Posté le 11 février 2016 - 17:10
Strange, since I hadn't accessed the project since I delivered it to the client.
The problem seemed to be the integrated Groupware. As soon as I turned off Groupware Integration everything was fine.
Does anyone actually use this? It seems like a good idea but it also seems rather buggy. For instance, the install program that I generate never seems to include wd200gpu.dll so unless I remember to manually add it to the application directory the program crashes the first time it is run. Also some times the groups and users I set up seem to disappear.
Garry
//hostimage.webdev.info/avatars/q1pH1BxRvNQy9RUIigcLiw
Membre enregistré
4 messages
Posté le 02 février 2017 - 01:19
Hi Fabrice,
I am running into the same error with my program. Where can I find this "file structure updater" to run?
Thanks,
David