Accueil → WINDEV 22 → Windows 10 April 2018 update Problem
Windows 10 April 2018 update Problem
Débuté par Rasta, 14 mai 2018 19:36 - 6 réponses
Posté le 14 mai 2018 - 19:36

Since Windows 10 April 2018 Update came out, all the clients that have been updated cannot connect to the local server where the application and database are located, while those that have older version of Windows 10 or Windows 8 and 7 can.

I have tried installing HFSQL Control Center on the client machine and tried to connect to the database on the server to see if it would work, and it connected without any problems.

Problem happens when I run my application on the client machine, I get an error saying that connection could not be established.
Error code: 74000
Level: non-fatal error
WD55 error code: 4000

One workaround was that I copied application .exe file and all .dll files to the local machine, and when I run it like that, it also connects to the server without any problems.
This is bad solution as I want to control all clients from the server, but it is a temporary solution until I find out what they did in Windows 10 April 2018 update that is causing these problems.

Did anyone else have any problems with Windows 10 Update??

Kind Regards,
Posté le 14 mai 2018 - 19:47
Today, I experienced the same problem with one client PC.
This problem is not WX DLLs or somthing similar. Is just one of the Windows 10 beauties !!!:mad:
The solution ?
After completion of the update, reboot and everything was Ok.!!

Vassilis Boutsikas
Posté le 14 mai 2018 - 22:35

Everything works fine with win10pro-64bit redstone 1803 and I also update to
v23 hfSQL server side and couldn't find any issue by far.

I do have win10pro-64/win7/64-32 clients connections to win10pro-64bit redstone 1803
with wx works a charm.

Can you tell what wx version/hardware that you're using?
I guess it's the windows defender blocks the connection indeed.


Posté le 15 mai 2018 - 18:30
Regards to all

I have similar problem with connection but all problems was on server side. If you try to install HF Center on client side and connect from server on Windows 10 updated to latest version you will see all works fine.

What I am do.
Delete all Windows firewall rules on SERVER HFSQL for port 4900 and add new (same TCP and UDP) 4900 port. Now all PC's updated or not can make connection.

Maybe you have also same situations.
Posté le 17 mai 2018 - 15:37
Hi everybody,

pcsoft published an article on the problem:

it's in french, but google translate is your friend

Best regards
Posté le 17 mai 2018 - 15:51
Hi Fabrice, translation to English ...

What to do under "Windows 10 April 2018 Update" (1803) if network communications (HFSQL, Email...) fail?

Workstations on which the update "Windows 10 April 2018 Update" (1803) may no longer be able to connect to a data server, or send emails.

For example, a WINDEV application will no longer be able to:

connect to the client/server HFSQL engine,
connect to a database via ODBC, OLE DB,
send an email.

This connection block occurs when the application executable runs under "Windows 10 April 2018 Update":

is on a shared resource on a Windows server,
AND that this shared resource does not have SMBv2 (Server Message Block) enabled.

In this case no code or compilation changes need to be made to the WINDEV application. It is only a change of Windows that induces this new behavior.

The solution is to enable SMBv2 on the share, or place the application on another share that has SMBv2. This version of "Windows 10 April 2018 Update" requires the use of SMBv2 for security reasons, otherwise communication features are blocked.

The following page contains complete information about SMBv2 (Server Message Block) :


Translated with www.DeepL.com/Translator
Posté le 18 mai 2018 - 13:21
Hi all,

I'm sorry I ever got trapped into using Windows 10. Every update seems to introduce new problems.
Just like Firefox -that seems to have an update every time I start it- fell from being my favorite browser to most annoying browser.
Fortunately WX products have only one update a year ;)

Kind regards,